PC 911
Share This Article

Category Archives for codec

Quicktime Issues with Qualcomm Purvoice Codec

I recently experienced an issue with QuickTime playing sound in my self created movies. I reviewed all the data concerning my videos to see if I could identify something unique about the videos or the player. After a few hours I noticed all of the movies that did not have sound were encoded with the Qualcomm Purevoice codec.

I researched intensely on QuickTimes website with no luck. I even spent fourty minutes on the phone with a QuickTime support technician only to have him tell me I would have to go and find a copy of the codec (which is no longer supported by the company) and install it. He stated specifically that it was not an issue with QuickTime. Despite me arguing about the fact that it worked previously he would not be swayed.

I decided to search deeper. In reviewing the QuickTime application logs I noticed I had received an upgrade recently. Shazaaaam! Maybe I had a direction to go with. Now I just had to figure out what my previous version was.

I discovered that my previous version of QuickTime was 7.1.6 so of course I went on an intensive search to find an installer. Once I located and installed the older version of QuickTime and after restarting of course; I once again had sound in my videos.

After curing my issue I contacted Apple again. I used my ticket number to contact the same technician and told him I had discovered the issue. As I explained to him that apparently either the codec or the ability of QuickTime to understand this codec had been removed from the QuickTime version 7.3 that I had installed. I told him if he would like I would be more than happy to tell him a work around for it, that I was sure with all of the forum questions on this same issue he would probably make many Apple customers happy.

This part just floored me, believe it or not I was told if I would like to go post it in there forums I could. What a crock (I thought) he wasn’t willing to help out his own customers by posting the information in a TID. It took me a few seconds to calm down (which I did), I told him why would I volunteer my time for a job that he is supposed to do? So I calmly explained that I’m sure this information would generate traffic on a website so I would just put it on one of our company websites.

Of course none of this even phased him. Apple is always talking about how there market share is increasing, maybe with all that new money they can hire some courteous technicians who actually desire to do their job by helping people.

Bottom line if you have any videos that do not play sound after upgrading your version of QuickTime, you might check to see what codec was used for the audio. If the audio was encoded with the Qualcomm Pure voice codec then a simple work around is to install QuickTime version 7.1.6.

I am unsure if the new 7.4 versions have a fix for this issue, but from the response I got from Apples’ technician it wasn’t like they were going to change anything. With this in mind I have not tried the latest versions to see if the codec is played in them. I use this codec all the time for older training videos and I am unwilling to change from a version which I know works to a version that may not.